Tanto jodí que andó

Los comentarios de este artículo han sido cerrados por ser obsoleto:

Una de las características del desempleo es el “alpedismo forzado” y por eso me puse a investigar.
Lo que siempre quise hacer andar aquí es o el Compiz o el Beryl, alguno de los dos con mi maldita ATI Radeon Xpress 1100.
La ATI Radeon no soportan Composite (que no se bien que hace), una característica necesaria para el escritorio XGL.
Bueno, no era tan así, muchas personas han padecido el mismo problema y le han encontrado solución.
Teniendo en cuenta mi caso, tener instalado Ubuntu Feisty con Gnome, los paquetes del Compiz vienen instalados.

Crear el archivo /usr/local/bin/startxgl.sh

#!/bin/sh
xsetroot -fg black &
Xgl :1 -fullscreen -ac -accel xv -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

chmod a+x startxgl.sh

Crear el archivo /etc/X11/xsessions/xgl.desktop
Editarlo:
[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

http://video.google.com/googleplayer.swf?docId=-2045001266474050600&hl=es

Ésto es Compiz+Gnome, pero voy por más: ¡BERYL + KDE! :mrgreen:

Anuncios

5 comments

  1. Agustin hice andar el 7.04 con beryl y es mortal, despues voy a hacer unos videitos para subir a youtube.

  2. Uuuuh, sí. Quiero ver eso andando.
    ¿Lo hiciste andar con XGL o con el X solo?
    Como mi ATI no soporta Composite tuve que hacer andar el Compiz con el servidor Xgl. El problema del servidor Xgl es que no funciona el Direct Rendering (DRI) y por lo tanto no puedo usar cosas como… Google Earth y el protector de pantalla glMatrix tampoco 😦
    Bueno, vos me contarás después…

    pd: acordate que con Ubuntu 64 algunas cosas se te van a complicar para hacer andar, según conocidos que tienen AMD 64.

  3. lo hice andar con los drivers que trae el ubuntu por default, lo de ati tienen ese problema que decis, asi que con lo que trae funciono.

  4. Hola, yo tengo ese problema, ya tengo instalado el driver de la ati radeon xpress 1100, tambien tengo el beryl instalado, pero no he logrado tener los efectos, la verdad solo tengo aceleracion en el escritorio gnome, en xgl no logro hacer que los engranes tengan mas de 500 FPS, espero que me puedas orientar, te dejo mi correo para poder obtener tu ayuda.

    Saludos

  5. Gracias por comentar en mi weblog.
    Por ese problema vas a tener que esperar que:
    – ATI saque un driver que funcione bien.
    – o que Xgl soporte DRI.
    No conozco otra alternativa.

Los comentarios están cerrados.